[PATCH] D53059: [NFC] Fix the regular expression for BE PPC in update_llc_test_checks.py

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 9 21:57:12 PDT 2018


MaskRay added inline comments.


================
Comment at: utils/UpdateTestChecks/asm.py:53
 
+ASM_FUNCTION_PPC_BE_RE = re.compile(
+    r'^_?(?P<func>[^:]+):[ \t]*#+[ \t]*@(?P=func)\n'
----------------
Can this be merged with `ASM_FUNCTION_PPC_RE`? If not, is it possible to extract the common part to a variable `ASM_FUNCTION_PPC_COMMON` (you make give it a better name)?


================
Comment at: utils/UpdateTestChecks/asm.py:245
       'mips': (scrub_asm_mips, ASM_FUNCTION_MIPS_RE),
-      'powerpc64': (scrub_asm_powerpc64, ASM_FUNCTION_PPC_RE),
-      'powerpc64le': (scrub_asm_powerpc64, ASM_FUNCTION_PPC_RE),
+# Including the dashes in the triple so PPC BE does not subsume LE.
+      'powerpc64-': (scrub_asm_powerpc64, ASM_FUNCTION_PPC_BE_RE),
----------------
The leading tab should be replaced with spaces.


Repository:
  rL LLVM

https://reviews.llvm.org/D53059





More information about the llvm-commits mailing list