[PATCH] D52897: AMDGPU: Rename isAmdCodeObjectV2 -> isAmdHsaOrMesa

Konstantin Zhuravlyov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Oct 4 11:26:54 PDT 2018


kzhuravl created this revision.
kzhuravl added reviewers: arsenm, scott.linder, t-tye.
Herald added subscribers: tpr, dstuttard, yaxunl, nhaehnle, wdng, jvesely.

The isAmdCodeObjectV2 is a misleading name which actually checks whether the os
is amdhsa or mesa.

Also add a test to make sure we do not generate old kernel header for code
object v3.


https://reviews.llvm.org/D52897

Files:
  lib/Target/AMDGPU/AMDGPUAsmPrinter.cpp
  lib/Target/AMDGPU/AMDGPUSubtarget.h
  lib/Target/AMDGPU/SIFrameLowering.cpp
  lib/Target/AMDGPU/SIISelLowering.cpp
  lib/Target/AMDGPU/SIMachineFunctionInfo.cpp
  test/CodeGen/AMDGPU/code-object-v3.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D52897.168333.patch
Type: text/x-patch
Size: 7116 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20181004/fa9453be/attachment.bin>


More information about the llvm-commits mailing list