[PATCH] D52764: [Intrinsic] Add llvm.minimum and llvm.maximum instrinsic functions

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 2 19:43:59 PDT 2018


arsenm added inline comments.


================
Comment at: lib/CodeGen/SelectionDAG/SelectionDAGBuilder.cpp:5588
+  case Intrinsic::minimum:
+    setValue(&I, DAG.getNode(ISD::FMINNAN, sdl,
+                             getValue(I.getArgOperand(0)).getValueType(),
----------------
Either as a dependency or an after-step, I think the DAG nodes should be renamed to match the intrinsic


Repository:
  rL LLVM

https://reviews.llvm.org/D52764





More information about the llvm-commits mailing list