[PATCH] D52694: [bindings/go] Add EraseFromParent

Ayke via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Sep 29 09:20:15 PDT 2018


aykevl added inline comments.


================
Comment at: bindings/go/llvm/ir.go:1213
 // Operations on instructions
+func (v Value) EraseFromParentAsInstruction()      { C.LLVMInstructionEraseFromParent(v.C) }
 func (v Value) InstructionParent() (bb BasicBlock) { bb.C = C.LLVMGetInstructionParent(v.C); return }
----------------
whitequark wrote:
> Nit: I'd call this `EraseInstructionFromParent`. (Also I'd deprecate `EraseFromParent` and rename it to `EraseBasicBlockFromParent`, but I'm not the Go bindings code owner so it's not my call.)
Yes, that sounds better but I've kept it consistent with EraseFromParentAsFunction and EraseFromParentAsGlobal. Should it be changed, then?


Repository:
  rL LLVM

https://reviews.llvm.org/D52694





More information about the llvm-commits mailing list