[PATCH] D49954: [InstCombine] Fold Select with binary op

Sanjay Patel via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jul 30 07:28:36 PDT 2018


spatel added inline comments.


================
Comment at: lib/Transforms/InstCombine/InstCombineSelect.cpp:66
+static Instruction *
+foldSelectInstWithBinaryOp(SelectInst &Sel, InstCombiner::BuilderTy &Builder) {
+  Value *Cond = Sel.getCondition();
----------------
spatel wrote:
> foldSelectBinOpIdentity() would be a more descriptive name.
Remove unused Builder param.


https://reviews.llvm.org/D49954





More information about the llvm-commits mailing list