[PATCH] D49505: [scudo] Simplify internal names (NFC)

Kostya Kortchinsky via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jul 18 13:04:35 PDT 2018


cryptoad created this revision.
cryptoad added reviewers: alekseyshl, eugenis.
Herald added subscribers: Sanitizers, delcypher.

There is currently too much redundancy in the class/variable/* names in Scudo:

- we are in the namespace `__scudo`, so there is no point in having something named `ScudoX` to end up with a final name of `__scudo::ScudoX`;
- there are a lot of types/* that have `Allocator` in the name, given that Scudo is an allocator I figure this doubles up as well.

So change a bunch of the Scudo names to make them shorter, less redundant, and
overall simpler. They should still be pretty self explaining (or at least it
looks so to me).

The TSD part will be done in another CL (eg `__scudo::ScudoTSD`).


Repository:
  rCRT Compiler Runtime

https://reviews.llvm.org/D49505

Files:
  lib/scudo/scudo_allocator.cpp
  lib/scudo/scudo_allocator.h
  lib/scudo/scudo_allocator_combined.h
  lib/scudo/scudo_allocator_secondary.h
  lib/scudo/scudo_tsd.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D49505.156136.patch
Type: text/x-patch
Size: 12761 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20180718/b9faef2a/attachment-0001.bin>


More information about the llvm-commits mailing list