[PATCH] D48172: [CostModel][AArch64] Add some initial costs for SK_Select and SK_PermuteSingleSrc

Evandro Menezes via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jun 19 10:39:31 PDT 2018


evandro added inline comments.


================
Comment at: lib/Target/AArch64/AArch64TargetTransformInfo.cpp:964
+    static const CostTblEntry SelectTbl[] = {
+        {ISD::VECTOR_SHUFFLE, MVT::v2i32, 1},
+        {ISD::VECTOR_SHUFFLE, MVT::v4i32, 2},
----------------
Independently of the costs, this lookup table could be simplified to a test on the number of vector elements.


================
Comment at: lib/Target/AArch64/AArch64TargetTransformInfo.cpp:979
+    static const CostTblEntry PermuteTbl[] = {
+        {ISD::VECTOR_SHUFFLE, MVT::v2i32, 1},
+        {ISD::VECTOR_SHUFFLE, MVT::v4i32, 2},
----------------
Ditto.


Repository:
  rL LLVM

https://reviews.llvm.org/D48172





More information about the llvm-commits mailing list