[PATCH] D47407: [LoopInstSimplify] Re-implement the core logic of loop-instsimplify to be both simpler and substantially more efficient.

Alina Sbirlea via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 29 10:46:54 PDT 2018


asbirlea accepted this revision.
asbirlea added a comment.
This revision is now accepted and ready to land.

LGTM. Looks like a clean simplification to me.



================
Comment at: llvm/lib/Transforms/Scalar/LoopInstSimplify.cpp:131
+    // Delete any dead instructions found thus far now that we've finished an
+    // iteration.
+    if (!DeadInsts.empty()) {
----------------
Nit: "an iteration over all instructions in all blocks." perhaps.
For code readability it would be easier to understand IMO. Alternatively "// end loop over instructions", "// end loop over blocks" for above closing braces, but that seems too much.


Repository:
  rL LLVM

https://reviews.llvm.org/D47407





More information about the llvm-commits mailing list