[PATCH] D47244: [llvm-mca] Rename the RetireControlUnit into RetireStage. NFC.

Andrea Di Biagio via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed May 23 02:30:37 PDT 2018


andreadb accepted this revision.
andreadb added a comment.

A couple of minor nits. Otherwise it LGTM too.



================
Comment at: tools/llvm-mca/Backend.cpp:41
   InstRef IR;
+
   Dispatch->preExecute(IR);
----------------
Backend.cpp should not be modified by this patch. Please get rid of this line diff.


================
Comment at: tools/llvm-mca/DispatchStage.h:11-12
 ///
 /// This file implements classes that are used to model reorder buffers and
 /// the hardware dispatch logic.
 ///
----------------
Can you improve the description? The old description is no longer valid.


================
Comment at: tools/llvm-mca/RetireStage.h:88
 
+  // This is a no-op for now.
+  virtual bool execute(InstRef &IR) override final { return true; }
----------------
This comment can be removed as it doesn't add much.


https://reviews.llvm.org/D47244





More information about the llvm-commits mailing list