[PATCH] D47206: Code cleanup in preparation for adding LTO for wasm. NFC.

Rui Ueyama via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 22 10:53:56 PDT 2018


ruiu added inline comments.


================
Comment at: Common/ErrorHandler.cpp:64
+void lld::diagnosticHandler(const DiagnosticInfo &DI) {
+  SmallString<128> ErrStorage;
+  raw_svector_ostream OS(ErrStorage);
----------------
nit: while you are here, please rename this `S` because we usually use shorter names for this kind of variable.


================
Comment at: ELF/Config.h:199
   unsigned LTOPartitions;
-  unsigned LTOO;
+  unsigned LTOOptLevel;
   unsigned Optimize;
----------------
`LTOO` is an odd name but intentional. All options are named after their corresponding command line options, and this option corresponds to -lto-o, so it should be LTOO.


Repository:
  rLLD LLVM Linker

https://reviews.llvm.org/D47206





More information about the llvm-commits mailing list