[PATCH] D45204: [X86][MIPS][ARM] New machine instruction property 'isMoveReg'

Quentin Colombet via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri May 18 13:58:30 PDT 2018


qcolombet added a comment.
Herald added a subscriber: atanasyan.

> As you can see I left VMOVRRD ARM instruction as FIXME since it is more complicated copy.

Yes, I saw that :).

> I'm not quite sure whether I should consolidate getRegSequenceInputs and getExtractSubregInputs into isCopyInstr or just use them as they are?

I would just leave them as they are. I was just pointing them out in case you wanted to see how we've done that so far.

> Or maybe just rename isCopyInstr into isSimpleCopyInstr?

Up to you.

> I could check that. But I suppose that it would be better to upgrade it with separate patch since I've already have one patch on the stack that depends on this functionality?

Definitely a different patch. I wanted to give other pointer on the kind of usages we may want to do with this callback.

why can't you do your analysis before the instructions are lowered (i.e., when all that stuff are still copies).

> [...] only at this pass existing DBG_VALUEs are propagated to other blocks.

I see, that's unfortunate but I understand.


https://reviews.llvm.org/D45204





More information about the llvm-commits mailing list