[PATCH] D38768: Add remarks describing when a pass changes the IR instruction count of a module

Jessica Paquette via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 15 15:46:44 PDT 2018


paquette updated this revision to Diff 146947.
paquette added a comment.

A couple more changes:

- `int` -> `unsigned` for `getInstructionCount` and friends.
- Change names of things that include "IR" to "Instruction".
- Add a few more comments.


https://reviews.llvm.org/D38768

Files:
  include/llvm/IR/Function.h
  include/llvm/IR/LegacyPassManagers.h
  include/llvm/IR/Module.h
  lib/Analysis/CallGraphSCCPass.cpp
  lib/IR/Function.cpp
  lib/IR/LegacyPassManager.cpp
  lib/IR/Module.cpp
  test/Other/size-remarks.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D38768.146947.patch
Type: text/x-patch
Size: 15567 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20180515/263b0a21/attachment.bin>


More information about the llvm-commits mailing list