[PATCH] D46832: [ELF] Change arguments to match D46831

George Rimar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon May 14 08:05:03 PDT 2018


grimar accepted this revision.
grimar added a comment.
This revision is now accepted and ready to land.

LGTM with a nit.



================
Comment at: ELF/InputFiles.cpp:134
   for (std::unique_ptr<DWARFCompileUnit> &CU : Dwarf->compile_units()) {
+    auto warnForError = [](Error Err) {
+      handleAllErrors(std::move(Err),
----------------
Since it is a variable, it should be uppercase: `WarnForError`

I would name it simpler though. For example - `Report`.


Repository:
  rLLD LLVM Linker

https://reviews.llvm.org/D46832





More information about the llvm-commits mailing list