[PATCH] D44999: Strip @VER suffices from the LTO output

Rui Ueyama via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 28 13:41:28 PDT 2018


ruiu accepted this revision.
ruiu added a comment.
This revision is now accepted and ready to land.

LGTM



================
Comment at: ELF/InputFiles.cpp:269
+template <class ELFT> ArrayRef<Symbol *> ObjFile<ELFT>::getGlobalSymbols() {
+  return makeArrayRef(this->Symbols).slice(this->FirstNonLocal);
+}
----------------
off-topic, but maybe we should rename this FirstGlobal. NonLocal is probably more technically correct, but colloquially Local <-> Global is much easier to digest.


https://reviews.llvm.org/D44999





More information about the llvm-commits mailing list