[PATCH] D42805: [utils] Refactor utils/update_{, llc_}test_checks.py to share more code

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Feb 2 10:40:55 PST 2018


MaskRay added a comment.

If you prefer different scripts for different purposes:

  utils/update_opt_test_checks.py   input: LLVM IR  ; CHECK lines: LLVM IR
  utils/update_llc_test_checks.py   input: LLVM IR  ; CHECK lines: assembly
  utils/update_cc_test_checks.py    input: C/C++/ObjC/..  ; CHECK lines: assembly or LLVM IR

If you did not mind merging `update_test_checks.py` and `update_llc_test_checks.py`, we could rename and merge these scripts by their input format:

  utils/update_ir_test_checks.py      input: LLVM IR  ; CHECK lines: assembly or LLVM IR
  utils/update_cc_test_checks.py     input: LLVM IR  ; CHECK lines: assembly or LLVM IR

I know little about MIR but it seems `utils/update_mir_test_checks.py` is totally different.


Repository:
  rL LLVM

https://reviews.llvm.org/D42805





More information about the llvm-commits mailing list