[PATCH] D42698: [GraphTraits] Add support for iterating over children edges.

David Li via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jan 30 23:21:01 PST 2018


davidxl added inline comments.


================
Comment at: include/llvm/ADT/GraphTraits.h:56
+  // static ChildEdgeIteratorType child_edge_begin(NodeRef)
+  // static ChildEdgeIteratorType child_edge_end(NodeRef)
+  //     Return iterators that point to the beginning and ending of the
----------------
Is there a convention on the naming here? why not call it out_edge_begin|end?  

Related, any need for  incoming edge iterations?


Repository:
  rL LLVM

https://reviews.llvm.org/D42698





More information about the llvm-commits mailing list