[PATCH] D41664: Remove test which assumed array cookies can't be poisoned when using an operator new defined in a class

Filipe Cabecinhas via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jan 15 10:59:00 PST 2018


filcab added a comment.

In https://reviews.llvm.org/D41664#975091, @kcc wrote:

> > Technically it is. Just like overriding malloc,
>
> That's a weak analogy. You can't override malloc and still use asan with it.


Derp, I forgot the open source version doesn't allow this. No problem.

>> Especially since we already have the escape hatch anyway, for special cases.
> 
> Which escape hatch do you mean?

I meant the `poison_array_cookie` flag.

How about this:
A `-fsanitize-address-poison-all-array-new` or similar (it would be all *except* placement new... Haven't got a better name, though).
That way, a user would be able to poison more array-new operators than the current solution. But we wouldn't break any legal C++ code.

Thank you,
Filipe


Repository:
  rCRT Compiler Runtime

https://reviews.llvm.org/D41664





More information about the llvm-commits mailing list