[PATCH] D41417: [hwasan] Implement -fsanitize-recover=hwaddress.

Evgenii Stepanov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Dec 19 16:43:24 PST 2017

eugenis added inline comments.

Comment at: compiler-rt/lib/hwasan/hwasan.cc:255
-template<bool IsStore, unsigned LogSize>
+template<bool Recover, bool IsStore, unsigned LogSize>
 __attribute__((always_inline, nodebug))
kcc wrote:
> I'd prefer enums to booleans, for better readability
good idea!


More information about the llvm-commits mailing list