[PATCH] D36704: [CodeGen] Improve the consistency of instruction fusion

Evandro Menezes via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Nov 27 12:16:58 PST 2017


evandro added inline comments.


================
Comment at: llvm/lib/CodeGen/MacroFusion.cpp:90
+      SUnit *SU = SI.getSUnit();
+      if (SI.isWeak() || (SI.getKind() != SDep::Order && SI.isCtrl()) ||
+          &FirstSU == SU || FirstSU.isSucc(SU))
----------------
fhahn wrote:
> Would it make sense to move this code to a function (maybe just a closure in this function? I suspect the fact that we use isPred/isSucc makes things slightly tricky? :(
Where would you suggest, as a new method in `SUinit`?


https://reviews.llvm.org/D36704





More information about the llvm-commits mailing list