[PATCH] D40365: [ELF] Rename .bss.rel.ro to .data.rel.ro.bss for some Linker Scripts.

Rui Ueyama via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Nov 23 18:06:51 PST 2017


ruiu accepted this revision.
ruiu added a comment.
This revision is now accepted and ready to land.

LGTM



================
Comment at: ELF/Writer.cpp:292
   Add(InX::Bss);
-  InX::BssRelRo = make<BssSection>(".bss.rel.ro", 0, 1);
+  // If there is a SECTIONS command and a .data.rel.ro section name use name
+  // .data.rel.ro.bss so that we match in the .data.rel.ro output section.
----------------
nit: add a blank line before a comment.


================
Comment at: ELF/Writer.cpp:295
+  // This makes sure our relro is contiguous.
+  bool IsSectionsDataRelRoOS =
+      Script->HasSectionsCommand && findSection(".data.rel.ro");
----------------
nit: It feels a bit too long. I'd name HasDataRelRo or something like that.


https://reviews.llvm.org/D40365





More information about the llvm-commits mailing list