[PATCH] D39685: AMDGPU: Handle or in multi-use shl ptr combi

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Nov 13 23:14:07 PST 2017


arsenm added inline comments.


================
Comment at: lib/Target/AMDGPU/SIISelLowering.cpp:5123
   // TODO: Support or
-  if (N0.getOpcode() != ISD::ADD || N0->hasOneUse())
+  if ((N0.getOpcode() != ISD::ADD && N0.getOpcode() != ISD::OR) &&
+      !N0->hasOneUse())
----------------
rampitec wrote:
> || N0->hasOneUse() is more readable in my view.
I'm not sure what you mean, that would remove the early return


https://reviews.llvm.org/D39685





More information about the llvm-commits mailing list