[PATCH] D34956: [ELF] - Store pointer to PT_LOAD instead of pointer to first section (FirstInPtLoad) in OutputSection

Rui Ueyama via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Sep 6 11:25:38 PDT 2017


ruiu accepted this revision.
ruiu added a comment.
This revision is now accepted and ready to land.

LGTM



================
Comment at: ELF/LinkerScript.cpp:773
+  Out::ProgramHeaders->PtLoad = nullptr;
+  FirstPTLoad->First = findFirstSection(FirstPTLoad);
 
----------------
`First` is too terse. The member should be renamed `FirstSec` in a follow-up patch.


https://reviews.llvm.org/D34956





More information about the llvm-commits mailing list