[PATCH] D36899: [ARM] Check the right order for halves of VZIP/VUZP if both parts are used

Martin Storsjö via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Aug 19 12:05:57 PDT 2017


mstorsjo added a comment.

In https://reviews.llvm.org/D36899#846598, @compnerd wrote:

> Do you think it may be worthwhile to extract the operation into a function?
>
>   static unsigned SelectPairHalf(unsigned Elements, ArrayRef<int> Mask, unsigned Index) {
>     if (Mask.size() == Elements * 2)
>       return Index / Elements;
>     return Mask[Index] == 0 ? 0 : 1;
>   }
>


Hmm, maybe. I want this backported to 5.0 though, so I'd rather not to make too much factorization in the fix itself. Perhaps a separate factorization commit on top afterwards, that doesn't have to be backported?


https://reviews.llvm.org/D36899





More information about the llvm-commits mailing list