[PATCH] D36502: [ARM] Tidy-up Cortex-A15 DPR-SPR optimizer implementation

Florian Hahn via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Aug 9 03:02:37 PDT 2017


fhahn accepted this revision.
fhahn added a comment.
This revision is now accepted and ready to land.

LGTM, this looks like a NFC to me and range-based for loops make the code easier to read. Please check the loop I added a comment to before committing.



================
Comment at: lib/Target/ARM/A15SDOptimizer.cpp:222
         }
         for (MachineRegisterInfo::use_instr_iterator
              II = MRI->use_instr_begin(Reg), EE = MRI->use_instr_end();
----------------
While you are at it, could we use a range based for loop here too? Looks like the iterator is dereferenced when used.


https://reviews.llvm.org/D36502





More information about the llvm-commits mailing list