[PATCH] D35639: [LTO] Prevent dead stripping and internalization of symbols with sections

Peter Collingbourne via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jul 25 11:01:57 PDT 2017


pcc added inline comments.


================
Comment at: lib/Object/IRSymtab.cpp:256
 
+  if (TT.isOSBinFormatELF() && isValidCIdentifier(Base->getSection()))
+    setStr(Uncommon().ELFCIdentifierSectionName,
----------------
I wouldn't check whether the section name is a C identifier here, as that is the client's responsibility. That probably means that the field should be renamed to just `SectionName`.


https://reviews.llvm.org/D35639





More information about the llvm-commits mailing list