[PATCH] D34781: Introduce a MCReloc class

Rafael Avila de Espindola via llvm-commits llvm-commits at lists.llvm.org
Wed Jul 19 21:26:19 PDT 2017


Gerolf Hoflehner via Phabricator <reviews at reviews.llvm.org> writes:

> Gerolf added a comment.
>
> It is not clear to me if and how the original questions have been answered by this patch yet. Could you elaborate and add comments, please? Much appreciate!
>
> What relocation should we map FK_Data_1 to? What if IsPCRel was set to true?
> What is the addend? FixedValue or Target.getConstant()?
> What is the meaning of "foo - bar at got"?
> There is *a lot* of duplicated code is the various obj writers.

I am not sure I understand your comment. This is what this revision
starts to fix.

For example, there is now only one addend: Reloc.getConstant(). It is
also impossible now to represent "foo - bar at got" since we store a symbol
instead of a symbolref for b.

Cheers,
Rafael


More information about the llvm-commits mailing list