[PATCH] D35135: Refactor MemoryMappingLayout::Next to use a single struct instead of output parameters. NFC.

Francis Ricci via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jul 11 11:10:36 PDT 2017


fjricci added inline comments.


================
Comment at: lib/sanitizer_common/sanitizer_procmaps.h:39
+  ~MemoryMappedSegment() {}
+
+  uptr start;
----------------
alekseyshl wrote:
> I think it might improve readability a bit if we add IsReadable(), IsWriteable(), IsExecutable() and IsShared() functions here (although latter is not needed at the moment).
This cleans things up a lot more than I would've expected initially, thanks!


https://reviews.llvm.org/D35135





More information about the llvm-commits mailing list