[PATCH] D33892: Align definition of DW_OP_plus with DWARF spec [1/3]

Adrian Prantl via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jun 6 10:58:29 PDT 2017


aprantl added inline comments.


================
Comment at: lib/Bitcode/Reader/MetadataLoader.cpp:536
 
+  void upgradeMetadataExpression(uint64_t FromVersion,
+                                 MutableArrayRef<uint64_t> Expr,
----------------
Let's rename this to `upgradeDIExpression`.


================
Comment at: test/Bitcode/DIExpression-deref.ll:15
+; CHECK: !DIExpression(DW_OP_plus_uconst, 0, DW_OP_deref, DW_OP_LLVM_fragment, 8, 32)
+!6 = !DIExpression(DW_OP_deref, DW_OP_plus_uconst, 0, DW_OP_LLVM_fragment, 8, 32)
+; CHECK: !DIExpression(DW_OP_plus_uconst, 0, DW_OP_deref)
----------------
This seems wrong. This file is supposed to be the disassembled version of the .bc file, so it should contain the old DIExpression to test the bitcode upgrade. (The CHECK is fine though).


https://reviews.llvm.org/D33892





More information about the llvm-commits mailing list