[PATCH] D33162: IR: Give function GlobalValue::getRealLinkageName() a less misleading name: getPGOName().

Peter Collingbourne via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon May 15 15:19:28 PDT 2017


pcc updated this revision to Diff 99068.
pcc added a comment.

- Rename and reword a comment


https://reviews.llvm.org/D33162

Files:
  llvm/include/llvm/IR/GlobalValue.h
  llvm/lib/Analysis/OptimizationDiagnosticInfo.cpp
  llvm/lib/Analysis/TargetLibraryInfo.cpp
  llvm/lib/CodeGen/AsmPrinter/CodeViewDebug.cpp
  llvm/lib/CodeGen/AsmPrinter/DwarfUnit.cpp
  llvm/lib/CodeGen/AsmPrinter/WinException.cpp
  llvm/lib/CodeGen/SelectionDAG/SelectionDAGBuilder.cpp
  llvm/lib/IR/DiagnosticInfo.cpp
  llvm/lib/LTO/LTO.cpp
  llvm/lib/Target/X86/X86ISelLowering.cpp
  llvm/lib/Target/X86/X86WinEHState.cpp
  llvm/lib/Transforms/Instrumentation/AddressSanitizer.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D33162.99068.patch
Type: text/x-patch
Size: 11966 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170515/b0d11a78/attachment.bin>


More information about the llvm-commits mailing list