[PATCH] D33105: [AMDGPU] Turn register pressure estimation into forward tracker

Stanislav Mekhanoshin via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon May 15 09:21:17 PDT 2017


rampitec added inline comments.


================
Comment at: lib/Target/AMDGPU/GCNRegPressure.cpp:359
+
+  MaxPressure = max(MaxPressure, CurPressure);
+}
----------------
vpykhtin wrote:
> arsenm wrote:
> > vpykhtin wrote:
> > > arsenm wrote:
> > > > std::max, not sure how this builds for you
> > > this is overloaded max for GCNRegPressure
> > Probably should name it something else
> I thought to choose better name for it as it doesn't compare two pressures and returning larger but instead constructs new pressure using maximum values from both, what would be better name here?
buildMax() maybe?


Repository:
  rL LLVM

https://reviews.llvm.org/D33105





More information about the llvm-commits mailing list