[PATCH] D33162: IR: Give function GlobalValue::getRealLinkageName() a less misleading name: getPGOName().

Peter Collingbourne via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri May 12 20:19:06 PDT 2017


pcc created this revision.
Herald added a subscriber: mehdi_amini.

This function gives the wrong answer on some non-ELF platforms in some
cases. The function that does the right thing lives in Mangler.h. To try to
discourage people from using this function, give it a different name.

Yes, this introduces calls to a function named getPGOName() in code that
has nothing to do with PGO, but don't shoot the messenger.


https://reviews.llvm.org/D33162

Files:
  llvm/include/llvm/IR/GlobalValue.h
  llvm/lib/Analysis/OptimizationDiagnosticInfo.cpp
  llvm/lib/Analysis/TargetLibraryInfo.cpp
  llvm/lib/CodeGen/AsmPrinter/CodeViewDebug.cpp
  llvm/lib/CodeGen/AsmPrinter/DwarfUnit.cpp
  llvm/lib/CodeGen/AsmPrinter/WinException.cpp
  llvm/lib/CodeGen/SelectionDAG/SelectionDAGBuilder.cpp
  llvm/lib/IR/DiagnosticInfo.cpp
  llvm/lib/LTO/LTO.cpp
  llvm/lib/Target/X86/X86ISelLowering.cpp
  llvm/lib/Target/X86/X86WinEHState.cpp
  llvm/lib/Transforms/Instrumentation/AddressSanitizer.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D33162.98871.patch
Type: text/x-patch
Size: 11542 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170513/a85216e8/attachment.bin>


More information about the llvm-commits mailing list