[PATCH] D32667: [Polly] Introduce VirtualUse. NFC.

Michael Kruse via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu May 4 08:30:05 PDT 2017


Meinersbur updated this revision to Diff 97832.
Meinersbur marked 11 inline comments as done.
Meinersbur added a comment.

Pre-commit update

- Spelling/grammar mistakes found by Tobias
- Doxygen comment for verifyUses
- Skip non-statement BBs entirely instead of various workarounds
- Some more/nicer comments
- Rename (Inter/Intra)Value to Inter/Intra for consistency with other enum elements
- Rename UseType to UseKind to adhere style policy http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly (and to not make clear this has nothing to do with llvm::Type)


https://reviews.llvm.org/D32667

Files:
  include/polly/Support/VirtualInstruction.h
  lib/Analysis/ScopBuilder.cpp
  lib/CMakeLists.txt
  lib/CodeGen/BlockGenerators.cpp
  lib/Support/VirtualInstruction.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D32667.97832.patch
Type: text/x-patch
Size: 25008 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170504/efeee361/attachment.bin>


More information about the llvm-commits mailing list