[PATCH] D31552: [InstCombine] Teach SimplifyDemandedInstructionBits that even if we reach an instruction that has multiple uses, if we know all the bits for the demanded bits for this context we can go ahead and create a constant.

Sanjay Patel via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 12 08:00:12 PDT 2017


spatel accepted this revision.
spatel added a comment.
This revision is now accepted and ready to land.

LGTM. It would be nice to lift everything in the:

  if (Depth != 0 && !I->hasOneUse()) {

block into a helper function to make it easier to read as an NFC change ahead of this. SimplifyDemandedUseBits has grown to over 700 lines.


https://reviews.llvm.org/D31552





More information about the llvm-commits mailing list