[PATCH] D31481: Change the error message format for undefined symbols.

Rafael Ávila de Espíndola via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 30 10:52:02 PDT 2017


rafael added inline comments.


================
Comment at: lld/ELF/Error.cpp:83
 
+  if (PrevMultiline)
+    *ErrorOS << "\n";
----------------
Maybe factor these 3 lines into a small helper method?


================
Comment at: lld/ELF/InputSection.cpp:264
+
+  // Find a function symbol that encloses a given location.
+  for (SymbolBody *B : getFile<ELFT>()->getSymbols())
----------------
Why does it have to be a function? Don't we want the same drag when, for example, a vtable has an undefined reference?


https://reviews.llvm.org/D31481





More information about the llvm-commits mailing list