[PATCH] D30952: Native PDB reader was swapping module and object file names

Zachary Turner via llvm-commits llvm-commits at lists.llvm.org
Tue Mar 14 17:05:38 PDT 2017


I'm not opposed to a name change at some level or another, but our getName
and getLibraryName has to return the same thing as DIA's. Right now
experimentation shows that IDiaSymbol::getName() returns the first of those
two strings and in the serialized record. "Module" and "object" just come
from the fact that they use the same name.

As long as getName() returns the first field and getLibraryName() returns
the second (which we have to since that's what DIA does), we can call them
anything. Alternatively we could stop using getName() and getLibraryName()
entirely in PDBSymbolCompiland and call them something else, but if the api
is going to mirror dia, then it should return the same values, and ideally
they should either be named exactly as they are in the reference
implementation (for cross verification), or completely differently
On Tue, Mar 14, 2017 at 4:34 PM Adrian McCarthy via Phabricator <
reviews at reviews.llvm.org> wrote:

> amccarth abandoned this revision.
> amccarth added a comment.
>
> I'm not completely convinced this is the wrong thing to do, but I won't
> fight it further.  I've compensated for the backwards naming in my next
> patch.
>
>
> https://reviews.llvm.org/D30952
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170315/49027b6a/attachment.html>


More information about the llvm-commits mailing list