[PATCH] D29512: [PGO] Directory name stripping in global identifier for static functions

Teresa Johnson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Feb 3 16:00:04 PST 2017


tejohnson added inline comments.


================
Comment at: lib/IR/Globals.cpp:159
+    else {
+      if (StaticFuncStripDirNamePrefix != 0)
+        FileName = stripDirPrefix(FileName, StaticFuncStripDirNamePrefix);
----------------
davidxl wrote:
> getGlobalIdentifier is a low level interface. Move this into getPGOFuncName
Rong and I discussed this - putting it here ensures the same naming scheme is used for PGO and for the ThinLTO index. Although for ThinLTO we will likely not want this enabled. I'm not sure if there is a good way to enforce that.


https://reviews.llvm.org/D29512





More information about the llvm-commits mailing list