[PATCH] D28476: [Analysis] Add LF_ prefix to LibFunc enums in TargetLibraryInfo. (NFC)
David L. Jones via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jan 20 17:23:04 PST 2017
dlj added a comment.
In https://reviews.llvm.org/D28476#652131, @efriedma wrote:
> I guess you could argue that TargetLibraryInfo in particular is extremely likely to cause problems in the future, and therefore we should preemptively rename all the library functions to avoid problems.
Right... that's the impetus, so fopen64 may simply be a red herring. I called this out as "portability" in the summary, since the enumerators are names that could be macros on a conforming system. Do you have a specific suggestion for something that I could re-word?
More information about the llvm-commits