[PATCH] D27825: [AVX-512][InstCombine] Teach InstCombine to converted masked vpermv intrinsics into shufflevector instructions

Simon Pilgrim via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Dec 16 02:49:06 PST 2016


RKSimon added inline comments.


================
Comment at: lib/Transforms/InstCombine/InstCombineCalls.cpp:2165
+
+      return replaceInstUsesWith(*II, V);
+    }
----------------
Move the mask code to a helper function? Isn't it likely we'll need it again for future avx512 intrinsic combines?


https://reviews.llvm.org/D27825





More information about the llvm-commits mailing list