[PATCH] D27778: Rename InputSection.cpp:getSymVA to getTargetVA.

Davide Italiano via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 14 14:45:45 PST 2016

davide added a comment.

In https://reviews.llvm.org/D27778#622835, @silvas wrote:

> In https://reviews.llvm.org/D27778#622811, @davide wrote:
> > I am in favour of this change. I think the name is quite explanatory/clear.
> >  Oracle docs (https://docs.oracle.com/cd/E23824_01/html/819-0690/chapter6-54839.html) use the wording "storage unit affected by the reloc", but I prefer target =)
> Not quite. "storage unit affected by the reloc" is the location that is being mutated by the relocation, not the thing the relocation "points at". Using the terminology from that page, I think the only term it uses is "value of the symbol whose index resides in the relocation entry" for RelocTarget.

Oh, yeah, nvm. LGTM anyway.


More information about the llvm-commits mailing list