[PATCH] D27694: [ARM] Add ARMISD::VLD1DUP to match vld1_dup more consistently

Renato Golin via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 14 02:41:48 PST 2016


rengolin accepted this revision.
rengolin added a reviewer: rengolin.
rengolin added a comment.
This revision is now accepted and ready to land.

Hi Eli,

Nice patch! I only have a few nits inline, but LGTM. Thanks!

--renato



================
Comment at: lib/Target/ARM/ARMISelLowering.cpp:10697
 
+/// PerformVDUPCombine - Target-specific dag combine xforms for ARMISD::VDUP.
+static SDValue PerformVDUPCombine(SDNode *N,
----------------
Maybe adding a one-line comment as to which pattern you want to combine here, as it isn't obvious.


================
Comment at: test/CodeGen/ARM/vlddup.ll:177
+  store i8* %add.ptr, i8** %a, align 4
+  %r.sroa.0.0..sroa_idx8 = getelementptr inbounds %struct.__neon_int8x8x2_t, %struct.__neon_int8x8x2_t* %agg.result, i32 0, i32 0
+  store <8 x i8> %lane, <8 x i8>* %r.sroa.0.0..sroa_idx8, align 8
----------------
nit: clean up the "sroa" names to make it slightly more readable.


Repository:
  rL LLVM

https://reviews.llvm.org/D27694





More information about the llvm-commits mailing list