[PATCH] D27390: [sanitizer] Use architecture/slice information when symbolizing fat Mach-O files on Darwin

Kuba (Brecka) Mracek via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 8 04:59:17 PST 2016


kubabrecka added inline comments.


================
Comment at: lib/sanitizer_common/sanitizer_common.h:684
+}
+
 const uptr kModuleUUIDSize = 16;
----------------
filcab wrote:
> I'm guessing you added this to two reviews so you commit either first but you'll merge the definitions later, right?
Right.


================
Comment at: lib/sanitizer_common/sanitizer_symbolizer_libcdep.cc:340
   }
   return false;
 }
----------------
filcab wrote:
> Maybe `return buf && ParseSymbolizePCOutput(buf, stack);` instead of the `if`?
> Same thing below.
I think that would be less readable.


================
Comment at: test/asan/TestCases/Darwin/haswell-symbolication.cc:51
+// REQUIRES: x86_64h
+// REQUIRES: shell
+
----------------
filcab wrote:
> Why?
Yeah, the "REQUIRES: shell" doesn't make sense here.  I misunderstood what it's used for.


Repository:
  rL LLVM

https://reviews.llvm.org/D27390





More information about the llvm-commits mailing list