[PATCH] D26567: Improve DWARF parsing speed by improving DWARFAbbreviationDeclaration

Adrian Prantl via llvm-commits llvm-commits at lists.llvm.org
Mon Nov 14 15:15:39 PST 2016


aprantl added inline comments.


================
Comment at: lib/DebugInfo/DWARF/DWARFAbbreviationDeclaration.cpp:187
+
+// Get the fixed byte size of this Form if the Form is fixed in byte size.
+Optional<uint8_t> DWARFAbbreviationDeclaration::AttributeSpec::getByteSize(
----------------
This comment should be on the declaration and a doxygen comment.


================
Comment at: lib/DebugInfo/DWARF/DWARFAbbreviationDeclaration.cpp:192
+    return ByteSize;
+  return DWARFFormValue::getFixedByteSize(Form, &U);
+}
----------------
Maybe it's easier to read to have this as a ?: one-liner inlined the class declaration?


https://reviews.llvm.org/D26567





More information about the llvm-commits mailing list