[PATCH] D25587: Introduce llvm FormatVariadic

Zachary Turner via llvm-commits llvm-commits at lists.llvm.org
Wed Nov 2 15:43:32 PDT 2016


zturner updated this revision to Diff 76798.
zturner added a comment.

1. Remove UDL syntax due to objections raised by chandlerc at .
2. Added  conversion operators to `std::string` and `SmallString<N>` to reduce the verbosity of formatting and saving the result as a string.
3. Changed the name from `format_string` to `formatv` to reduce the verbosity again as a result of no longer having UDL syntax available.


https://reviews.llvm.org/D25587

Files:
  include/llvm/ADT/STLExtras.h
  include/llvm/Support/FormatAdapters.h
  include/llvm/Support/FormatCommon.h
  include/llvm/Support/FormatProviders.h
  include/llvm/Support/FormatVariadic.h
  include/llvm/Support/FormatVariadicDetails.h
  include/llvm/Support/NativeFormatting.h
  include/llvm/Support/YAMLTraits.h
  include/llvm/Support/raw_ostream.h
  lib/Support/CMakeLists.txt
  lib/Support/FormatVariadic.cpp
  lib/Support/NativeFormatting.cpp
  lib/Support/raw_ostream.cpp
  unittests/Support/CMakeLists.txt
  unittests/Support/FormatVariadicTest.cpp
  unittests/Support/NativeFormatTests.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D25587.76798.patch
Type: text/x-patch
Size: 77017 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20161102/dc6b0af5/attachment.bin>


More information about the llvm-commits mailing list