[PATCH] D25440: [Target] remove TargetRecip class; move reciprocal estimate isel functionality to TargetLowering

Eric Christopher via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 18 13:50:03 PDT 2016


On Tue, Oct 18, 2016 at 1:45 PM Sanjay Patel <spatel at rotateright.com> wrote:

> spatel added inline comments.
>
>
> ================
> Comment at: include/llvm/Target/TargetLowering.h:260-266
> +  int getSqrtEnabled(EVT VT, MachineFunction &MF) const;
> +
> +  /// Return a ReciprocalEstimate enum value for a division of the given
> type
> +  /// based on the function's attributes. If the operation is not
> overridden by
> +  /// the function's attributes, "Unspecified" is returned and target
> defaults
> +  /// are expected to be used for instruction selection.
> +  int getDivEnabled(EVT VT, MachineFunction &MF) const;
> ----------------
> echristo wrote:
> > Bit of a bikeshed but these two functions sound like they're seeing if
> sqrt and div are instructions in the hardware.
> I'll take any suggested improvements. :)
>
> Note that I reverted this commit at rL284513 because I screwed something
> up with the StringRefs while parsing the function attribute.
>
>
It's long, but how about getRecipEstimateDivEnabled?


> A bot said: "AddressSanitizer: initialization-order-fiasco" (!)
>
>
How judgmental ;)

-eric
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20161018/f7f30846/attachment.html>


More information about the llvm-commits mailing list