[PATCH] D25631: [LV] Avoid emitting trivially dead instructions

Michael Kuperstein via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 18 11:05:56 PDT 2016

mkuper accepted this revision.
mkuper added a comment.
This revision is now accepted and ready to land.

LGTM with a nit about naming.

Comment at: lib/Transforms/Vectorize/LoopVectorize.cpp:4243
+  for (auto &Induction : *Legal->getInductionVars()) {
+    auto *Ind = Induction.first;
+    auto *IndUpdate = cast<Instruction>(Ind->getIncomingValueForBlock(Latch));
Ind/Induction combined with the two "autos" is confusing. Maybe make the type of Ind explicit (or call it IndPhi?)?


More information about the llvm-commits mailing list