[PATCH] D16697: Updating .debug_line section version information to match DWARF version.

Katya Romanova via llvm-commits llvm-commits at lists.llvm.org
Mon Oct 10 11:54:32 PDT 2016


kromanova updated this revision to Diff 74153.
kromanova added a comment.
Herald added a subscriber: mehdi_amini.

Here is the revised patch. I have addressed Paul Robinson's comments.
Sorry for the delay. Somehow this patch patch fell off my radar.

Question: If you grep LLVM sources for " DWARF2Line, you'll see that a lot of identifier names imply that line_table is DWARF2. e.g. "DWARF2LineOpcodeBase". I suspect this should be changed to avoid confusion. Do you agree? Separate NFC patch?


Repository:
  rL LLVM

https://reviews.llvm.org/D16697

Files:
  lib/MC/MCDwarf.cpp
  test/DebugInfo/AArch64/line-header.ll
  test/DebugInfo/Generic/empty.ll
  test/DebugInfo/X86/debug-line-version.s
  test/DebugInfo/X86/empty.ll
  test/DebugInfo/X86/stmt-list-multiple-compile-units.ll
  test/MC/ELF/debug-line.s
  test/MC/ELF/debug-line2.s
  test/MC/ELF/debug-loc.s
  test/MC/ELF/discriminator.s
  test/MC/ELF/empty-dwarf-lines.s
  test/MC/MachO/file.s
  test/MC/MachO/gen-dwarf.s
  test/MC/MachO/loc.s

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D16697.74153.patch
Type: text/x-patch
Size: 11821 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20161010/b6b13816/attachment.bin>


More information about the llvm-commits mailing list