[PATCH] D24957: [x86][ms-inline-asm] use of "jmp short" in asm is not supported

Reid Kleckner via llvm-commits llvm-commits at lists.llvm.org
Wed Oct 5 10:12:09 PDT 2016


rnk requested changes to this revision.
rnk added a comment.
This revision now requires changes to proceed.

Actually, there are some minor style issues, but otherwise this is OK.



> X86AsmParser.cpp:2136
> +  if (Name == "jmp" && isParsingIntelSyntax() && isParsingInlineAsm()) {
> +    StringRef nextTok = Parser.getTok().getString();
> +    if (nextTok == "short") {

Follow the LLVM naming convention, "NextTok"

> X86AsmParser.cpp:2139
> +      SMLoc NameEndLoc =
> +        NameLoc.getFromPointer(NameLoc.getPointer() + Name.size());
> +      // Eat the short keyword

format

> X86AsmParser.cpp:2145
> +      InstInfo->AsmRewrites->emplace_back(AOK_Skip, NameEndLoc,
> +        nextTok.size() + 1);
> +    }

formatting

Repository:
  rL LLVM

https://reviews.llvm.org/D24957





More information about the llvm-commits mailing list