[PATCH] D24318: AArch64: Use TTI branch functions in branch relaxation

Matt Arsenault via llvm-commits llvm-commits at lists.llvm.org
Wed Sep 14 07:48:05 PDT 2016


arsenm added inline comments.

================
Comment at: include/llvm/Target/TargetInstrInfo.h:530
@@ +529,3 @@
+  /// removed instructions.
+  virtual unsigned RemoveBranch(MachineBasicBlock &MBB,
+                                int *BytesRemoved = nullptr) const {
----------------
rovka wrote:
> Since you're touching all of these, it might be a good time to fix them to follow the naming convention (removeBranch etc).
I thought about doing this, but then it would require touching all of the many other call sites in the one patch. I can do this in a follow up


https://reviews.llvm.org/D24318





More information about the llvm-commits mailing list