[PATCH] D23405: [ELF] Do not add start and end symbols in case they are defined in linker script

Rui Ueyama via llvm-commits llvm-commits at lists.llvm.org
Fri Aug 12 14:13:46 PDT 2016


ruiu accepted this revision.
ruiu added a comment.
This revision is now accepted and ready to land.

LGTM


================
Comment at: ELF/Writer.cpp:525
@@ +524,3 @@
+template <class ELFT>
+static void addRequiredSynthetic(StringRef Name, OutputSectionBase<ELFT> *Sec,
+                                 typename ELFT::uint Val) {
----------------
Is `Required` a good name? Maybe I'd name this simply `addSynthetic` and add a comment to describe its semantics (defines a symbol unless there's already a defined symbol with the same name.)


https://reviews.llvm.org/D23405





More information about the llvm-commits mailing list