[PATCH] D22951: [ADT] Add filter_iterator for filtering elements

Tim Shen via llvm-commits llvm-commits at lists.llvm.org
Fri Aug 12 12:22:58 PDT 2016


timshen updated this revision to Diff 67880.
timshen marked an inline comment as done.
timshen added a comment.

Removed std::distance check. Changed name to filter_iterator and make_filter_range.


https://reviews.llvm.org/D22951

Files:
  include/llvm/ADT/STLExtras.h
  include/llvm/ADT/iterator.h
  unittests/Support/IteratorTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D22951.67880.patch
Type: text/x-patch
Size: 7094 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20160812/16050624/attachment.bin>


More information about the llvm-commits mailing list